Automated Printing Issue Reported
Incident Report for WhosOnLocation
Resolved
This incident has been resolved.
Posted Jun 15, 2017 - 08:18 UTC
Monitoring
Our engineers have been working hard on this issue and we are happy to say that we have just released a fix.

You do not need to do anything to apply this fix, the next time a badge pass is printed via your Kiosk or Sign In/Out Manager it should no longer produce an error. If you held off on applying the Windows Security Update (KB4022719) or have subsequently uninstalled this update, you can now safely install this security update.

If you have any further issues with printing, please let us know via our helpdesk - helpdesk@whosonlocation.com.
Posted Jun 15, 2017 - 04:32 UTC
Update
We have had a number of customers who have been able to resolve their printing issue by removing the Windows Update KB4022719. An alternative while this issue is being investigated further would be to use Firefox ESR which is unaffected by the Windows Update. If you would like to try printing from this browser, you can find instructions to set this up in one of these Helpdesk articles:

Link Printer - Kiosk PC - Firefox
https://helpdesk.whosonlocation.com/hc/en-us/articles/229322227-Link-Printer-Kiosk-PC-Firefox

Link Printer - Receptionist PC - Firefox
https://helpdesk.whosonlocation.com/hc/en-us/articles/229672468-Link-Printer-Receptionist-PC-Firefox

If you require any further assistance, please contact us at helpdesk@whosonlocation.com
Posted Jun 14, 2017 - 21:26 UTC
Identified
We are aware of an issue which is affecting some of our customers who use Automated Printing at their Kiosk or Sign In/Out Manager screen with Internet Explorer 11. A June 14 Windows security update prevents the MeadCo Script X browser plugin from functioning correctly which we rely on for automated printing.

More information can be found on the Mead Co website:
http://scriptx.meadroid.com/news/issue-with-ie-11-and-windows-update-of-14-june-2017.aspx

If you are affected, the temporary fix is to remove the security update as described on the Mead Co website.

We will update this post when we have further information.

We apologise for any inconvenience caused.
Posted Jun 14, 2017 - 20:03 UTC