Service Incident with us2.whosonlocation.com
Incident Report for WhosOnLocation
Resolved
We are happy to report that service has been restored. We apologise for any inconvenience caused by this incident.
Posted Feb 05, 2018 - 20:55 UTC
Investigating
We are experiencing an issue with one or more of our WhosOnLocation servers which may impact your WhosOnLocation experience. Our engineers are working to resolve the issue as soon as possible.

The affected server(s) are:
us2.whosonlocation.com

We are working with one of our upstream service providers to resolve this issue as soon as possible.
Posted Feb 05, 2018 - 20:29 UTC