Helpdesk Degraded Performance
Incident Report for WhosOnLocation
Resolved
This incident has been resolved.
Posted Mar 16, 2017 - 02:08 UTC
Identified
We are experiencing degraded performance from our Helpdesk. You may experience a delay in accessing the in app help widget or viewing our Helpdesk via helpdesk.whosonlocation.com.
Posted Mar 15, 2017 - 20:28 UTC